Jump to content
Attention: In order to reply to messages, create topics, have access to other features of the community you must sign up for an account.
Sign in to follow this  
TheSubwayStation

OpenBVE won't open on my Mac

Recommended Posts

Today, I went to openbve.org to download openbve on my mac. I downloaded it, and all of the dependencies, but it won't work. When I click on the OpenBVE icon, it appears in the dock for an instant but then disappears. Can anyone please help my figure out how to make it work?

Share this post


Link to post
Share on other sites

Today, I went to openbve.org to download openbve on my mac. I downloaded it, and all of the dependencies, but it won't work. When I click on the OpenBVE icon, it appears in the dock for an instant but then disappears. Can anyone please help my figure out how to make it work?

 

 

The same thing happens for me too. I am talking to error46146, Bstyles, and Queens Boulevard Express, trying to solve the problem.

Share this post


Link to post
Share on other sites

Hopefully some experienced OpenBVE users will be able to help us all out.

 

 

Experience OpenBVE mac users. I can help you with almost anything for OpenBVE Windows, still trying to figure out how to get the mac version running. I hope that mackoy makes a stable OpenBVE that is native compatible with mac soon, put it on the mac app store.

Share this post


Link to post
Share on other sites

Experience OpenBVE mac users. I can help you with almost anything for OpenBVE Windows, still trying to figure out how to get the mac version running. I hope that mackoy makes a stable OpenBVE that is native compatible with mac soon, put it on the mac app store.

 

I see.

Share this post


Link to post
Share on other sites

Ok, as the one who compiled the Mac app, you MUST have had the remaining required dependencies installed, which are SDL, OpenAL, and the Mono framework. Did you check whether those dependencies were installed?

 

And it was michelle who wrote OpenBVE. While one of the remaining official developers, odakyufan is just being a sitting duck, me and a few community OpenBVE members took action to rehost OpenBVE and the files.

 

the Mac app does take a bit to open, but it will eventually pop-up, assuming you installed the required dependencies.

Edited by -CT1660-

Share this post


Link to post
Share on other sites

I specifically remember installing all of them.

 

 

What is your Mac OS X version, and what processor? Because the Mac binary will only run on Intel Macs.

Share this post


Link to post
Share on other sites

I have Mac OS v10.6.5, and an intel processor.

 

 

You might need to update it to 10.6.8, Try that, and let me know if it will run.

Share this post


Link to post
Share on other sites

I have Mac OS v10.6.5, and an intel processor.

 

 

Not a Mac user myself although I am quite familiar with them, but you might need to upgrade your Mac OS to Lion or the upcoming Mountain Lion release...

Share this post


Link to post
Share on other sites

Not a Mac user myself although I am quite familiar with them, but you might need to upgrade your Mac OS to Lion or the upcoming Mountain Lion release...

 

 

The test system i tested my build on was Mac OS X 10.6.8, on a MacBook Pro, so it should work on Mac OS X 10.6.8 and newer.

 

screenshot20120602at904.png

 

screenshot20120602at904.png

Edited by -CT1660-

Share this post


Link to post
Share on other sites

I used to be able to get it to work a long time ago, but I deleted it for some reason. I don't know why. Ever since the OpenBVE site was taken down by Michelle, ish doesn't work.

Share this post


Link to post
Share on other sites

It is only compatible on Mac OS X Snow Leopard 10.6.8 and up. I have to upgrade my computer and see how that is going to work out.

 

TheSubwayStation, go into terminal, and type in

 

mono OpenBve.exe

 

If not, try this;

 

mono openbve.exe

Edited by trainguy97

Share this post


Link to post
Share on other sites

Thanks, Trainguy. The file is called OpenBVE.app, and I tried that. But this is what it said:

 

 

-bash: OpenBVE.app: command not found

 

UPDATE:

 

I tried entering:

 

/Applications/OpenBVE.app

 

But then it said:

 

 

-bash: /Applications/OpenBVE.app: is a directory

Edited by TheSubwayStation

Share this post


Link to post
Share on other sites

If you could get a hold of DJ Hammers, he is a Moderator of OpenBVE NYCTA Development, he uses it on mac. I will talk to him and see if he can help us out.

  • Upvote 1

Share this post


Link to post
Share on other sites

here's a trick i use manually on terminal. First on the terminal, type mono, then right click the openbve.app, and click on view package contents. Then go to Contents, then resources and drag and drop OpenBVE.exe into the terminal window, and then press enter. It should run.

  • Upvote 1

Share this post


Link to post
Share on other sites

here's a trick i use manually on terminal. First on the terminal, type mono, then right click the openbve.app, and click on view package contents. Then go to Contents, then resources and drag and drop OpenBVE.exe into the terminal window, and then press enter. It should run.

 

It keeps just saying:

 

No such file or directory

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.